MACD 精研汇总 MACD 精研汇总 首先来说说"macd二次翻红" "macd二次翻红"有"macd二次翻红有黄金"之说。MACD二次翻红 首先说说MACD,MACD是一个中线指标,用它不仅可判断大盘的中级走势,实践显示,在选股尤其是选强势股方面,MACD也有着十分重要的作用,如果运用得好,可以成功地相对低位捕捉到个股的起涨点。
w1:ma(c,5)ref(ma(c,5),1);60,n横盘天数,n1横盘的上下幅度REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)=(n1/100)and ref(v,1)ref(ma(v,5),1)and cross(v,ma(v,5))and cross(v,ma(v,10));81,条件:1:假设大前天创最近新高,要求这天涨幅是超过7%的大阳线,且创最近一个月的新高.2:那么前天,昨天,今天都收小K线,要求小K线实体xg:ref(c,3)/ref(c,4)1.07 and ref(c,3)=hhv(c,20)and count(abs((c-ref(c,1))/ref(c,1)0.02,3)))=3;
捕捉强势股之《MACD红柱堆积》捕捉强势股之《MACD红柱堆积》{红柱堆积}大 智 慧L2DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIFF,9);MACD:=2*(DIFF-DEA);LAST(MACD>0 AND DEA>0 AND MACD>REF(MACD,1))+1>3 AND C>REF(C,1) AND DYNAINFO(17)>0;{红柱堆积}通 达 信DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIFF,9);MACD:=2*(DIFF-DEA);DEA>0 AND MACD>0 AND EVERY(MACD>REF(MACD,1),3) AND C>REF(C,1) AND DYNAINFO(17)>0;
DRAWICON(ISLASTBAR=1 AND MACD<REF(MACD,1),HHV(MACD,42),2);UP:IF(DIFF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORBB9A00;DN:IF(DIFF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR4),VAR2),COLORAA00CC;波↓:IF(DIFF<REF(DN,1),DIFF,DRAWNULL),COLOR00FF00,LINETHICK3;波↑:IF(DIFF>REF(DN,1)AND DIFF<REF(UP,1),DEA,DRAWNULL),COLORFFFFFF,LINETHICK3;☆DEA:IF(DIFF>REF(DN,1),DIFF,DRAWNULL),COLORFF00FF,LINETHICK3;
选股公式5日,10日,20日,30日均线拐头向上选股公式。参数设置:N:缺省5 , N1 10 , n2 20,n3 30}MA(C,N)>=REF(MA(C,N),1),;MA(C,N1)>=REF(MA(C,N1),1),;MA(C,N2)>=REF(MA(C,N2),1),;MA(C,N3)>=REF(MA(C,N3),1),;
【兰博基尼】缠师用的MACD指标更新至3.0 - 公式下载区 - 缠中说禅学社——中国最好...【兰博基尼】缠师用的MACD指标更新至3.0.
cross(ref(ma(c,5),1),ref(ma(c,10),1)) and c>ma(c,5);xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l.xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;xg:ma(c,30)>ref(ma(c,30),1);count(abs(c-ref(c,1)/ref(c,1))ref(c,1),3)=3;xg:ma(c,20)>ref(ma(c,20),1);XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)REF(V,1)*2 AND C/REF(C,1)>1.05;
MACD二次绿柱缩短的选股公式,谢谢了。股价创新低,比较前后两个绿色macd片的最低值不再创新低(两绿中间出现一片红柱),甚至股价创新低,macd是红的,这样的选股公式。DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);DEA:=EMA(DIFF,9);A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));B1:REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05andcount((h-l)/l12,行情信息里的“涨幅”的原码。xg:cross(c,ma(c,10))andcross(c,ma(c,20))andcross(c,ma(c,30))andv>ref(v,1)3;w1:=ref(c,2)w2:=ref(h,2)>ref(h,1)andref(l,2)w3:=ref(h,1)>handref(l,1)xg:w1andw2andw3;xg:ref(v,1)=llv(ref(v,1),n)andv>ref(v,1)mandc>o;xg:ref(c,3)/ref(c,4)>1.07andref(c,3)=hhv(c,20)andcount(abs((c-ref(c,1))/ref(c,1)82,60与120均线距离在n%内。
AA7:=MA((AA4*0.96+AA5*96+AA6*0.96+AA1*0.558+AA2*0.558+AA3*0.558)/6,17);AA8:=MA((AA4*1.25+AA5*1.23+AA6*1.2+AA1*0.55+AA2*0.55+AA3*0.65)/6,17);AA9:=MA((AA4*1.3+AA5*3+AA6*1.3+AA1*0.68+AA2*0.68+AA3*0.68)/6,17);MACD6:= 2*(DIFF6-DEA6);MA(CLOSE,30)>REF(MA(CLOSE,30),1) and diff>0 and dea>0 AND MACD>REF(MACD,1) and b;MA(CLOSE,30)>REF(MA(CLOSE,30),1) AND DIFF>0 AND DEA>0 AND MACD>REF(MACD,1) AND B;
count(c<>72、今天收盘价在昨天收盘价-2%~2%之间c/ref(c,1)>0.98 and c/ref(c,1)<>73、收盘价在5日均线以上5天 count(c>ma(c,5),5)=5;74、N天前换手率大于8% REF(VOL/CAPITAL*100,N)>8;75、一条均线18MA 股价上涨后“缩量”回调到18MA XG:COUNT(V<>MA(C,18); N “缩量”回调的天数76、1.昨日量是n天以来最低量(n可调);(MA30>REF(MA30,1)) AND (REF(MA30,1)<=ref ="">REF(C,2)>REF(O,2) AND REF(C,1)
(为大家节约时间&nbsp...[转载]通达信公式  125个选股公式,解决选股难题!vol/ma(vol,10)3,两天内,累计下跌等于或超过20%选股.xg:(ref(c,2)-c)/c>0.2;4,股价是25天以来新低.xg:c5,选股:EXPMA 5日与10日金叉 并且第二天的收盘价在EXPMA的5日线以上.cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);6,请编买入公式:1. 将BIAS指标的参数设置为24日,将KD指标的参数设置为9;
满足后发出信号~w1:=ref(c,2)<ref(o,2);w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);w3:=ref(h,1)>h and ref(l,1)<l;xg:w1 and w2 and w3;18, 选出今日成交量大于昨日成交量一成的股票。xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;120,跳空高开后,三天内没有回补缺口ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);121,日涨幅小于3%C>0 AND C/REF(C,1) >1.03;122, 股价创30个交易日的新高H>ref(H,30);
CCI:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));MACD>0 AND MACD>REF(MACD,1) AND C>EMA(C,7) AND EMA(C,7)>EMA(C,30) AND CCI>100 AND C>REF(C,1) AND DYNAINFO(17)>0;CCI:=(TYP-MA(TYP,89))/(0.015*AVEDEV(TYP,89));MACD>0 AND MACD>REF(MACD,1) AND C>EMA(C,7) AND EMA(C,7)>EMA(C,30) AND CROSS(CCI,100) AND DYNAINFO(17)>0;
MACD:= 2*(DIFF-DEA);JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;<>二次金叉:CROSS(DIF,DEA) AND DIF>REF(DIF,AA+1) AND AA<20 AND DIF<0;<>
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORYELLOW;DEA :=EMA(DIFF,9),COLORGREEN;MACD:=2*(DIFF-DEA), COLORSTICK;A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));B1:=REF(C,A1 1)>C AND REF(DIFF,A1 1)<DIFF AND CROSS(DIFF,DEA);C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));D1:=REF(C,C1 1)<C AND REF(DIFF,C1 1)>DIFF AND CROSS(DEA,DIFF);
F:=100*(C-REF(C,1))/REF(C,1);P1:=IF(C<REF(O,1) AND F<0,1,0);P2:=IF(C<REF(O,2) AND F<0,1,0);TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);MACD := 2*(DIFF-DEA);J<20AND OPEN<MA(CLOSE,60) AND MACD>REF(MACD,1)AND (C>O OR C<O)AND C>1.04*REF(C,1)AND INDEXC>0.98*REF(INDEXC,1);
MACD卷土重来DIFF := EMA(CLOSE,9) - EMA(CLOSE,26);DEA := EMA(DIFF,12);MACD := 2*(DIFF-DEA);{红柱减值:IF(MACD<REF(MACD,1) AND REF(MACD,1)>0 AND REF(MACD,2)<REF(MACD,1),0.2,0);}红柱增值:=IF(MACD>REF(MACD,1) AND REF(MACD,1)>0 AND REF(MACD,2)>REF(MACD,1),0.2,0);{绿柱增值:=IF(MACD>REF(MACD,1) AND REF(MACD,1)<0 AND REF(MACD,2)>REF(MACD,1),0.2,0);}XD:10*(红柱增值) ;
A11:=LLV(C,A1)<REF(LLV(C,A1+1),A1+1) AND LLV(DIFF,A1)>REF(LLV(DIFF,A1+1),A1+1);LLV(DIFF,A1)>REF(LLV(DIFF,A1+A2+2),A1+A2+2);DIBL1:=(A11 OR A22 OR A33 OR A44 OR A55) AND DIFF<0 AND DIFF<DEA AND DIFF>REF(DIFF,1)AND DIFF>REF(DIFF,2);B11:=HHV(C,B1)>REF(HHV(C,B1+1),B1+1) AND HHV(DIFF,B1)<REF(HHV(DIFF,B1+1),B1+1);DINGBL1:=(B11 OR B22 OR B33 OR B44 OR B55) AND DIFF>0 AND DEA<DIFF AND DIFF<REF(DIFF,1)
GT:=DEA>REF(DEA,1) AND REF(DEA,1)<REF(DEA,2);GT2:=DEA<REF(DEA,1) AND REF(DEA,1)>REF(DEA,2);
同花顺分时MACD指标公式-同花顺公式-股旁网。PARTLINE(dea,dea>REF(dea,1),RGB(255,0,255),dea<REF(dea,1),RGB(0,255,255),1);DRAWTEXT(IF(b1>0,1,0),dea,''macd底背''),colorcyan;c1:=BARSLAST(REF(CROSS(0,Mb),1));d1:=REF(NEW,c1+1)<NEW AND REF(DEA,c1+1)>dEA AND CROSS(0,Mb) AND diff>0;DRAWTEXT(IF(d1>0,1,0),dea,''macd顶背''),colormagenta;
MACD缩脚的选股公式请教这个MACD缩脚的选股公式问题出在哪?本人新手,想编一个MACD缩脚和出现轧空棒(就是红柱缩小又放大)的选股公式,源码如下:DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);DEA:=EMA(DIFF,M);MACD:=2*(DIFF-DEA);A1:=REF(MACD,1)<MACD;A2:=REF(MACD,2)>=REF(MACD,1);A1 and A2;前半部分是引入的MACD公式,后半部分是求出上一日MACD为最小值的选股条件。